Login Error
Incident Report for AppNomu Business Services
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 21, 2024 - 22:25 EAT
Identified
We understand that there is an issue that prevents users from logging into their accounts to do operations, and neither does resetting passwords work.

Our engineers are working hard to resolve this issue as soon as possible and we will keep you posted once a fix has been implemented.
Posted Jan 21, 2024 - 20:27 EAT
This incident affects: Utility Payment, Airtime & Data purchase and sending, Withdrawing, Gift Cards purchase and sending, Loan Repayment and Savings, Card Payment, Onboarding/Client registration, and Dashboard and Login.