Google Pay is currently unavailable
Incident Report for AppNomu Business Services
Postmortem

We sincerely apologize for the decision we have made to switch off the Google payment method that had been used by more than 20% of our clients who use prepaid cards.

We understand this has affected the way you make payment towards our services and products, the decision came when we needed to comply with the service provider who is Google and therefore as we undergo compliance, we are needed to pause the method momentarily, we have no timeline given for this but we are aware it should not take longer.

However, we have made it possible for Apple pay and to use this, you need to launch our website or web application on safari for apple or mac devices and our application for iOS users and you will be able to use Apple pay the same way Google pay has been working out. Other payment methods still exist and they have no incidents reported.

We hope you enjoy the new checkout experience!

Posted Sep 15, 2022 - 17:09 EAT

Resolved
While we tried to engineer this service together with our partners, we have decided to pause Google payment method so we can be sure of compliance. We understand this has affected most of our clients who have been adopted to this payment method because of being simple. We have made it more possible to use Apple pay and other payment methods available like Mobile money, card payment, barter, bank transfer within US and all local methods available in Nigeria.

We are doing tirelessly to make sure that Google pay comes back soon but unfortunately we are not able to provide a clear timeline, we will be sure to communicate to you across our channels once that option is back.
Apologize for inconveniences.
Posted Sep 15, 2022 - 16:57 EAT
Monitoring
Our service partner has just informed us about Google pay being currently unavailable for online payments. This is because they are doing several engineering about Google pay payment method and they have not yet provided clear timeline of when it should be up and running.

We know this might have affected your payment methods but we do still have Mobile money working fine, Apple pay, Barter payment method, and bank cards with no incident.
In the meantime, as we wait to hear from our service partner, you can be using the available payment methods in your country. We will provide communication once it has been restored.
Posted Sep 14, 2022 - 14:38 EAT
This incident affected: Card Payment.