Service partner registration
Incident Report for AppNomu Business Services
Resolved
Our upstream service provider has reported back to us and we will be resuming services in Uganda after a long waiting period to our affected clients. The issue happened because they needed to make sure we do comply with all the trading policy and enhancing a better user experience on our route.
All pending accounts should be activated soon and you will receive an email once the activation has been completed. Thanks for waiting as we were in touch with our upstream service provider.
Posted Sep 30, 2022 - 03:47 EAT
Monitoring
We are still having challenges registering our service partners for Airtime and data reselling in Uganda and Kenya, our team is aware of this challenges and all our hands are on decks to resolve the issue as soon as possible.
We would like to appeal of this issue and apologize to all clients that have been affected since last week.
The issue has been caused by our service partner endpoint and document verification system which is responding slowly upon checking and verifying national ID of the users for validations.

We understand you are going through hard times and there shall be a compensation of 20% your initial deposit to compensate you with the time you haven't been working
Posted Sep 14, 2022 - 08:59 EAT
This incident affected: Onboarding/Client registration.