Unable to accept prepaid Cards
Incident Report for AppNomu Business Services
Postmortem

For almost Five hours , we were not able to process payment from prepaid cards, both Mastercard and Visa cards as our system couldn't read the data of these cards to approve authentic payment.

Our engineers were informed earlier about this incident and worked so hard to resolve the implication until when things have turned to normal and the payment through prepaid cards is working fine from all regions.

What caused the issue was so many changing proxies by the clients who were using VPN and proxy connections which resulted into the system to block such cards so we could prevent fraud and spamming as many hackers use that method to steal sensitive data.

To make sure we do not get this challenge in the future, we have disabled possibility of making payment while using VPN connection or Proxy connection. You should not use any kind of VPN while using prepaid cards, otherwise your card will be declined.

Thank you for your patience as our team were working on this challenge.

Posted Sep 17, 2022 - 17:15 EAT

Resolved
For a few hours(5 hours), we were having challenges collecting Payments from prepaid cards, our engineers got to know about this earlier and had been working so tirelessly to resolve this issue.
Now prepaid card is working well and we apologize for the inconvenience and challenges you experienced during the downtime. This came when our system were not able to read accurate data from your car to provide a secure authentic payment verifications to our end point.
If you fail to use the prepaid card, kindly turn off VPN or any proxy so that your IP address do not get flagged, clear all the web browsing cache and retry payment. It should be successful.
Posted Sep 17, 2022 - 17:08 EAT
Monitoring
Well, we have been able to process online payment from prepaid virtual cards, Mastercard and visa cards, we have experienced a network glitch that is not able to verify the authenticity of the card to make sure we can verify the information on the card for successful payment processing.
Our engineers have known this earlier and they are working tirelessly to make sure everything is normal and you will be able to make payments as soon as possible.
We apologize for any inconveniences caused to you, you can try a variety of other payment options available like the real Debit or Visa cards, apple pay, Barter payment method, and Mobile money in the accepted countries as we resolve this as soon as possible.

The prepaid cards that had been already verified and still have funds, can make payments through, except new prepaid cards that are failing to be verified.
Posted Sep 17, 2022 - 12:46 EAT
This incident affected: Card Payment.