Prepaid Card Payment Failure
Incident Report for AppNomu Business Services
Postmortem

The incident has been solved and we can now confirm that you can make payment using the prepaid cards, Kindly note that only prepaid cards that accept 3D verifications can be used at the moment.

Posted Dec 19, 2023 - 23:52 EAT

Resolved
This incident has been resolved.
Posted Dec 19, 2023 - 23:51 EAT
Identified
We are aware of the incident that is happening where we are having issues with the prepaid card payment. Customers are not able to make payments using prepaid cards. Our engineers are working with the service provider to ensure the issue is resolved on time, and we will post a notification.

However, other payment methods are still working, including mobile money, Bank cards, PayPal, Apple Pay, and Google Pay
Posted Dec 19, 2023 - 15:10 EAT
This incident affected: Card Payment.